"Show Intention Action" is intermittently not working

I have seen some intermittent issues where the "Show Intention Action" does not work. The light bulb icon does not appear when the cursor is over the trouble spot, and Alt+Enter does not bring the actions list/menu up. (This is in 7.0.4 EAP build 7860).

For example, I was just doing some clean-up on a Class I had just finished. I had three Fields (a.k.a. instance variables) that were flagged as being able to convert to local. A quick Alt-Enter on the first two (to convert to local) worked fine, but I cloud not get the intention actions to come up for the third one. I also had some unused imports. So I ran an optimize imports, and then boom, the intention action for that third field worked.

This is just one example. I've experienced it at other times; especially with the Spell Checker plug-in; but that's one I use a lot given that I am a horrible speller and a worse typist ;) Has anyone else experienced a problem with the intention actions coming up? I just want to get a feel for things before I open a JIRA. JetBrains: Is there anything I can do that might help you in tracking the issue down? logs or CPU snapshot?

1 comment
Comment actions Permalink

I have experienced similar problems quite frequently. It does work sometimes, but really only some of the times. Here is another post that may be related :
http://www.jetbrains.net/devnet/message/5220486#5220486

Anything I can do to fix this ?

0

Please sign in to leave a comment.