"SDK is not set" error for Flex projects

I installed trial version of IntelliJ Ultimate on a fresh Windows 7, created new Flex project using IntelliJ wizard and set up sdk for project and module. When I try to build project I always get "Error:[Test]: SDK is not set for build configuration 'Test' (module 'Test')". SDK is set, because when it is not set red warning displayed at the bottom in the build configuratioin settings. I have tried Flex SDK 4.13 and old 4.6 from Adobe - same issue for both. I have tried to open existing project which compiles fine using IntelliJ on Mac, same issues. I have tried to reinstall IntelliJ Idea but it did not help. Any ideas?

Best Regards, Mark
2 comments
Comment actions Permalink

Please attach [LOG]/idea.log and [LOG]/build-log/build.log file (where [LOG] is folder that opens via Help | Show logs).

Are you using OS simulation like Parallels or Wine? If so you probably should сhange the location of IDE system/config/log/plugins folders in the [IDE installation]/bin/idea.properties file, don't use

${user.home}
, change it to some local fixed path with forward slashes. See https://intellij-support.jetbrains.com/entries/23348963
0
Comment actions Permalink

Thank you very much for the very quick response. Works perfectly now.  

0

Please sign in to leave a comment.