Ant build not running

I am using MAIA EAP 558 when i run my ant build i see a "Ant build completed successfully in 0s at 3:55:26 PM" without any error message. There is no indication of what went wrong

6 comments
Comment actions Permalink

This may happen with unknown command line argument, for example: http://www.jetbrains.net/jira/browse/IDEADEV-12783
Please, check the build file properties in IDEA.

Alexander.

0
Comment actions Permalink

I have not arguments or properties set for my build in intellij.Is there anything else i need to check?.

I tried different jdk's and also ant versions

0
Comment actions Permalink

Do you have anything in the Additional Classpath tab of ant build properties? If you do, could you try to remove all those jars? (Build may fail, but the question is: will it ever start.)

Alexander.

0
Comment actions Permalink

I tried removing my additional classpath jars and still doesnt work and doesnt give any error.

0
Comment actions Permalink

I am using IntelliJ IDEA 8.1.3 9886 and having the same problem you are describing.
Have you had any luck resolving it?
Like you I don't have any special arguments specified and I have tried specifying other Ant installations, and JDKs but no luck

I have now also tried this with Version 9 MAIA and have the same problem.

I am using the Linux version but running on Solaris, which may be significant but I don't think should be.

Ant builds work fine on 7.0.5

0
Comment actions Permalink

Resolved....

The problem for me was caused by a combination of the 1.5 JDK, the Stack Size on the IDEA Ant window, and the stack size in my Solaris shell.

The default Solaris shell stack is 10Meg (this can be changed with ulimit -s).
The default IDEA 8/9 Ant stack setting is 32Meg
The combination results in -Xss32m on the ant JVM command line causing the underlying shell fail because of a stack error, and IDEA doesn't catch the error.

Solution is to change the stack value on the ant window to 10Meg or less, if a bigger stack is required set the shell stack to a bigger value with ulimit before executing IDEA.

0

Please sign in to leave a comment.