IntelliJ IDEA (latest vrsion) not updating to latest version of plugin.

I use the latest version of IDEA for Linux, 13.1.4, (64-bit) and have the Dart plugin installed. I recently noticed that it is lacking several months behind with the latest version (I have 135.765 and the latest is 138.*) and does not seem to automatically update.
I tried to download the latest verion and install it manually, but it says "Plugin Dart is incompatible with current installation".

Why is this? Do I need webStorm for the latest version of Dart?

3 comments
Comment actions Permalink

You may notice in the Dart plugin page that each plugin version has 'since build' number that shows minimal IDE version required by the plugin. 138.* version branch is for IntelliJ IDEA 14 EAP, PhpStorm 8 EAP and WebStorm 9 EAP. WebStorm comes with the Dart plugin bundled out-of-the-box. IntelliJ IDEA 14 EAP and PhpStorm 8 EAP will allow you to install the latest Dart plugin version.

0
Comment actions Permalink

Can I upgrade to the new build? Or does it require a new license?

0
Comment actions Permalink

Early access builds do not require new licenses.


0

Please sign in to leave a comment.