[Flex] Whilst debugging, sometimes editor window will duplicate

Hey,

Great effort on bringing 13.1 live!
There seem to be one issue though for me. Whilst I'm debugging my Flex project and stepping through lines of code, very often I notice that editor window duplicates time after time, making the whole thing unusable.
Basically, another editor window pops up with the same file opened as I'm currently debugging.

Any suggestions?
Thanks.

21 comments

I've never seen the issue.
Are you sure you really get the same file in more than one editor tabs? May be they are equal but located in different folders? What happens if you start editiong in one of them and then switch to another?
Can you please attach screenshots?

0

Hey,

Sorry for the delay.
I've attached the screenshot. I think it might have to do with the vertical layout of my screen.

Btw. sorry but I had to blank most of the things out...



Attachment(s):
intellij.png
0

Nice joke :)

Meanwhile this seems to be a known issue, it should be fixed in the latest IntelliJ IDEA 14 EAP.

0

This issue seems to be not related to my problem, as:

a) I do not have "Split vertically", my orientation of the screen is vertical, as in portrait
b) I downlaoded latest EAP 14 and this issue is still occuring...

0

Unlikely screen orientation can cause the issue.
Unfortunately I still failed to reproduce.

0

Logs may help (Help | Show Logs). Logs contain project name, local paths and other data that seems to be sensitive to you, so I'm not sure if you can attach it here or send directly to me: alexander dot doroshko at jetbrains dot com.

0

Unfortunately I will not be able to attach logs, as they will not pass Legal & Compliance dept and they are too big to manually blank them out :(
Maybe the fact, that I'm using maven with flexmojos will help you?

There is nothing useful regarding the issue from the time of occurance of the issue. Only thing that logs state is compilation was successful...

0

Well, if no errors in log around the issue time then probably they won't help. Do you have any 3rd party plugins? Disabling may help.
Unlikely maven or flexmojos matter.
Is it 100% reproducible with some specific file? With all other files?
Will you have the same issue with any other debugger, e.g. Java debugger in IntelliJ IDEA 14?

0

I don't have any 3rd party plugins, just regulard IntelliJ installation.
This is reproducable with any other file.

This doesn't seem to happen with Java debugger.

0

Ok, I have some updates on this matter.
If I use different keys to go through lines with debugger, the problem doesn't occur anymore.

Does this shed any light?

0

Not yet. Not sure what you mean by  using different keys to go through lines with debugger.

0

When you are debugging, and stepping through the lines of code (F8).

When I'm using my custom assigned key to do that (ctrl+shift+alt+Q) it tends to open the editor window, as desribed above. However, when I use F8, or button on the debugger window it works properly

0

Ok, so it may be a shorcut conflict. You can check it in Settings | Keymap, press small 'Find action by shortcut' button in its top right corner and then press ctrl+shift+alt+Q. It will show you all actions mapped to this shortcut.

0

I added Ctrl+Alt+Shift+Q as a second shortcut for Step Over and used it a lot, but still failed to reproduce the issue.

0

How can I attach my whole keymap?

0

File | Export Settings...
Leave only Keymap checked.

0

Sorry for delay, was on vacation.
Step Over still works fine for me even when using Alt+Shift+Q from your keymap.

0

what about ctrl+alt+shift+z (equivalent to F9)? All this is intermittent.

0

Still do not see any problems. Stepping/resuming works. Editor is not duplicated.

0

Please sign in to leave a comment.