Debugging issues in 8.1.x EAPs

Anyone noticed any debugging problems in the recent 8.1 EAPs? A number
of times now, stepping has been problematic - sometimes IDEA just sits
there after I press F8 and the only way to jolt it into action seems to
be to go into the breakpoints dialog and change something e.g. delete a
breakpoint.
I've also noticed that it takes a long time for the execution point to
show in IDEA when a breakpoint is hit. The debugged app will freeze and
then some seconds later the execution point shows up.
I have no field/method breakpoints defined, and no special config on
breakpoints - they're just vanilla.

N.

7 comments
Comment actions Permalink

Hello Nathan,

Are you by any chance using JDK 1.6.0_14 as the target JDK?

Anyone noticed any debugging problems in the recent 8.1 EAPs? A
number
of times now, stepping has been problematic - sometimes IDEA just sits
there after I press F8 and the only way to jolt it into action seems
to
be to go into the breakpoints dialog and change something e.g. delete
a
breakpoint.
I've also noticed that it takes a long time for the execution point to
show in IDEA when a breakpoint is hit. The debugged app will freeze
and
then some seconds later the execution point shows up.
I have no field/method breakpoints defined, and no special config on
breakpoints - they're just vanilla.
N.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Dmitry Jemerov wrote:

Hello Nathan,

Are you by any chance using JDK 1.6.0_14 as the target JDK?


Hi Dmitry,

No I'm actually using 1.6.0_13 - should I be using _14 then? Is it a JDK
issue?

Thanks,
Nathan.

0
Comment actions Permalink

Nathan Brown wrote:

Dmitry Jemerov wrote:

>> Hello Nathan,
>>
>> Are you by any chance using JDK 1.6.0_14 as the target JDK?


Hi Dmitry,

No I'm actually using 1.6.0_13 - should I be using _14 then? Is it a JDK
issue?

Thanks,
Nathan.

I've moved to _14 and it still feels sluggish, but I haven't had any
'hangs' yet... should I be using _14?

N.

0
Comment actions Permalink

I'm experiencing the very sample problem. Stepping through code using F8 after a breakpoint is hit is painfully slow in the 8.1.x EAP's. The message that states evaluaing value of variables in the debug window takes forever. I'm on OSX.

Sanjiv

0
Comment actions Permalink

FYI, I'm running Mac OS X 10.6 (snow leopard), which has Java 1.6.0_13 installed.  I can't even get the debugger to start up my server program; it launches but it is very, very slow.  I end up having to run the executable outside of the debugger for it to work.

I've tried this on latest Diana and Maia builds, and both are the same result.

0
Comment actions Permalink

Eric H. wrote:

FYI, I'm running Mac OS X 10.6 (snow leopard), which has Java 1.6.0_13 installed. I can't even get the debugger to start up my server program; it launches but it is very, very slow. I end up having to run the executable outside of the debugger for it to work.

I've tried this on latest Diana and Maia builds, and both are the same result.

---
Original message URL: http://www.jetbrains.net/devnet/message/5240454#5240454

Sounds like it's possibly an issue with the later 1.6 JDK's then... no
word back from Dmitry yet though.

N.

0
Comment actions Permalink

Hello Nathan,

I don't have much to say unfortunately except for the fact that one of my
colleagues reported problems with debugging on 1.6.0_14.

>> FYI, I'm running Mac OS X 10.6 (snow leopard), which has Java
>> 1.6.0_13 installed. I can't even get the debugger to start up my
>> server program; it launches but it is very, very slow. I end up
>> having to run the executable outside of the debugger for it to work.
>>
>> I've tried this on latest Diana and Maia builds, and both are the
>> same result.
>>
>> ---
>> Original message URL:
>> http://www.jetbrains.net/devnet/message/5240454#5240454

Sounds like it's possibly an issue with the later 1.6 JDK's then... no
word back from Dmitry yet though.

N.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.