Hibernate JPA 2 Metamodel generation

Answered

I am trying to get IDEA 13.1.4 to generate the metamodels for my model classes.  I followed the instruction in help but the "Process Annotations" item never shows when I right click on a model class nor when I look in the Build menu.

I have all Java config which works just fine otherwise.  My settings in the Compiler/Annotation Processors are as follows:

  1. "Obtain processors from project classpath" is selected.
  2. Processor FQ name set to: org.hibernate.jpamodelgen.JPAMetaModelEntityProcessor
  3. Annotations Processor options: fullyAnnotationConfigured = true


I am not using the Default profile.  I created my own and associated my module with the new profile.  I have also tried invalidating my caches.  I have also tried removing the fully qualified name of the processor and just let IntelliJ find it in the classpath, did not work.


When I make the project I get the following message:

  1. Warning: java: Hibernate JPA 2 Static-Metamodel Generator 4.3.6.Final


That's it.  I get no other message I can find.

Any help is apperciated.

3 comments
Comment actions Permalink
  1. Go to Preferences -> Build, Execution, Deployment -> Annotation Processors;
  2. Check Enable annotation processing checkbox;
  3. In "Store generated sources relative to:" select Module content root.

Just ignore the "Processor FQ name" and have a try.

1
Comment actions Permalink

I'm using spring boot with gradle and lombok.

Any chance to get the JPA metamodel running with gradle and lombok?

0
Comment actions Permalink

@Alexander Straschil what is the issue? Have you tried to configured Gradle for this? Note that in case of a Gralde-based project IDE takes all configuration (for dependencies/building, structure) from build.gradle files.

0

Please sign in to leave a comment.