Resource bundle editor not working

Hi there,

I using the latest version of Intellij with ALL default configuration kept on installation (actually I have removed all versioning systems, but kept git and svn). Today I have tried to open a messages.properties file in order to edit it, but it only shows the text editor, there is no tab to switch to Resource Bundle editor.

editor.png

How to solve it? I have checked on the plugin manager as well but it shows that I have "properties support" installed and it shows nothing useful (that is not installed) for searches like 'budle', 'resources', 'properties' and 'messages'...

Any idea??

Thanks in advance.

4 comments

The resource bundle editor only becomes avaiable if you have more than one locale (or a default properties file and at least one locale) defined. Also, after defining a second locale, you need to close the (original) file and reopen it to see the resource bundle editor. (This latter "issue" is a bit of a bug.)

0

So I'm not able to edit a messages.properties with the graphical editor that helps me by managins special chars (like accents) until I have two locales?

Maybe I have not been clear in my first message, but all I need is a decent properties editor (like the one in eclipse) where I can type "São Paulo" as the value and it transforms to me to somenthing like "S\u00E3 Paulo"...

No lucky until I have two locales?

0

brunoskrebs wrote:

Maybe I have not been clear in my first message, but all I need is a decent properties editor (like the one in eclipse) where I can type "São Paulo" as the value and it transforms to me to somenthing like "S\u00E3 Paulo"...

Yeah , that wasn't clear :)

If you have the "Transparent native-to-ascii conversion" option turned on in the File Encoding settings, (and ptoperties files encoding set to the Java standard ISO-8859-1), IDEA will show the UTF-8 character ã in the editor, but file itself is encoded using the \u00E3 escape sequence. You can open it in an external plain text editor to verify. For more info, see:

To the best of my knowledge, there is not a quick way to toggle the "Transparent native-to-ascii conversion" on and off in the event you want to quickly see the file with the escape sequences. It'd be a small task though to write a plug-in to do it if you had a need for that.

    The value add of the resource bundle editor is being able to see/edit the values for a key from all locales simultaneously. The above transparent conversion is present for all properties files whether or not they are part of a resource bundle.

    0

    Thank you very very much, solved by just checking "Transparent native-to-ascii conversion" on File Encoding settings as you mentioned.

    Thanks again!

    0

    Please sign in to leave a comment.