Git merge - ignore whitespaces

Hey,

How do I turn on ignoring whitespaces during merge solving conflicts?
Jetbrains webpage says there should be a dropdown in idea diff tool, but there isn't one...

Is there a option to turn it on or was it removed?
I'm using 14 EAP, have been using idea 13. It doesn't exist in both.

Can you please advise?

5 comments
Comment actions Permalink

Very strange. Can you post a screenshot of the top of your diff dialog? For reference, below is a screenshot of what it should look like (and where the ignore whitespace setting should be). You may want to try to disable all third party plug-ins and restart. It's possible some plug-in is altering that dialog.

screenshot.png

0
Comment actions Permalink

Yes, diff window includes that option.
However, when I go to resolving conflicts it seems as though it is different tool? It does not include ignoring whitespaces dropdown...

0
Comment actions Permalink

Sounds like an external diff tool is being launched. You can check for this in IDEA in Settings > [IDE Settings] > External Diff Tools, most likely the "Use external merge tool" option. It's also possible a Git configuration is taking preference. (We use Mercurial, so I'm not as familiar with Git. But I assume you can define a diff tool to use for merge conflicts in Git like you can for Mercurial in your .hgrc/mercurial.ini settings.)

0
Comment actions Permalink

No, my settings do not indicate using external diff tool.
How would I check if it's git preference?

0
Comment actions Permalink

I really don't use Git, so I'v never done such. But here is the Git documentation on it: http://git-scm.com/book/en/Customizing-Git-Git-Configuration#External-Merge-and-Diff-Tools

Perhaps another IDEA user that uses Git regularly can provide some additional input.

0

Please sign in to leave a comment.