Haxe Flash Debugging

I havent used the debugger in a while and have been struggling to get it working with the latest 12.x version and haxe plugin 0.5.6

Bascially I am compiling an nme project by an nmml file to flash.
Linux does not connect to the player and windows only connects to the debug player after I right click and press debugger, but then I miss all the breakpoints.

Is anyone one else using flash debugging having with haxe plugin?

5 comments
Comment actions Permalink

I am experiencing the same issue with IntelliJ 12.0.2/Haxe Plugin 0.5.6. I am using Windows 7, though so I don't think it is OS related.

The flash player opens, it starts running the application. Breakpoints are not getting hit. After right clicking and running the Debugger, I get:

"h:\program files (x86)\intellij idea 12.0.1\jre\jre\bin\java.exe" -Dapplication.home=H:\flex_sdk_4.5.0.20967A -Xmx384m -Dsun.io.useCanonCaches=false -Dfile.encoding=UTF-8 -Djava.awt.headless=true -Duser.language=en -Duser.region=en -Xmx512m -classpath "H:\Program Files (x86)\IntelliJ IDEA 12.0.1\plugins\flex\lib\idea-fdb-4.5.0.20967-fix.jar;H:/flex_sdk_4.5.0.20967A/lib/fdb.jar" flex.tools.debugger.cli.DebugCLI
Adobe fdb (Flash Player Debugger) [build 20967]
Copyright (c) 2004-2007 Adobe, Inc. All rights reserved.
Waiting for Player to connect
Player connected; session starting.


Which tells me that the debugger should be now working. However even then I cannot hit a breakpoint. It seems to be broken.

0
Comment actions Permalink

I also discovered that if I hit pause button, even thought nothing seems to happen, the program will break in noname.as:1. And show the following stack/vars. The reference to noname.as:1 is bogus.

Screen Shot 2013-01-16 at 7.00.24 PM.png

0
Comment actions Permalink

Commented on the issue.

0
Comment actions Permalink

Did you ever get this working? I'm having the same issue in IntelliJ 13.1.4, Haxe plugin 0.7.1, no breakpoints are being hit!

0

Please sign in to leave a comment.