Before Launch -> Make

I have a run/debug configuration set up for remote debugging to a particular
machine and port. In the 'Before launch' settings I have both 'Make' and
'Run Ant target' unchecked. However when I try to connect to my remote application,
IDEA (Maia build #10313) insists on running Make anyway. Is this a bug or
am I doing something stupid? It's a bit of a showstopper for me for this
build unfortunately. If it's a bug let me know and I'll file a Jira.

(I just checked - it appears to happen for all my run configurations, not
just remote debugging).


5 comments
Comment actions Permalink

Hello Chris,

I have a run/debug configuration set up for remote debugging to a
particular machine and port. In the 'Before launch' settings I have
both 'Make' and 'Run Ant target' unchecked. However when I try to
connect to my remote application, IDEA (Maia build #10313) insists on
running Make anyway. Is this a bug or am I doing something stupid?
It's a bit of a showstopper for me for this build unfortunately. If
it's a bug let me know and I'll file a Jira.


Yes, this is a bug and it's already fixed so there's no need to file a JIRA.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Yes, this is a bug and it's already fixed so there's no need to file a
JIRA.


Ah OK thanks Dmitry, In that case I look forward to the next build :)


0
Comment actions Permalink

Chris Miller pisze:
>> Yes, this is a bug and it's already fixed so there's no need to file a
>> JIRA.


Ah OK thanks Dmitry, In that case I look forward to the next build :)

With remote deploy is the same.

as a workaround you need to uncheck 'Make' in Default Run Configuration.

0
Comment actions Permalink

As a workaround you need to edit Default Run Configuration and uncheck "Make" checkbox.

0
Comment actions Permalink

Ah thanks for the workaround, I hadn't thought of trying that. Back to #10313
I go... :)

As a workaround you need to edit Default Run Configuration and uncheck
"Make" checkbox.



0

Please sign in to leave a comment.