Idea 12 not stopping on python breakpoints

Hello,

I am running Idea 12.1.7 Ultimate (build #IU-129.1525, JRE 1.6.0_65, VM Java HotSpot 64-bit server VM by Apple Inc.) on OS X Mavericks. I have a project with a Django module, and I run it via the debug (I have a run configuration set up for it). Python plugin version is         2.10.2 (the latest I have the option of installing via the "Browse repositories" in the "Plugins" configuration menu).

It's running fine, but it's never stopping on any python code breakpoints - it just runs as if there was no breakpoints set at all. (Yes, I am using Debug and not Run).

The attached image shows the breakpoint in the "View breakpoints" dialog, so you can see that it's enabled and it should suspend the program when the breakpoint is encountered. What do I need to do to enable breakpoints again?

Screen Shot 2014-07-29 at 11.20.10.png

1 comment
Comment actions Permalink

Things I have tried to fix this with no changes:

1) Clearing all pyc files (both from idea and manually, before runs)
1) Invaidating caches and restarting
2) Creating a new project with the same source code
3) Reinstalling Idea
4) Reinstalling Idea after cleaning-up all the locations where Idea keeps configs and caches on a osx system
5) Installing older version of idea12 (12.0.4)
6) Changing Java version to 1.7 and back to 1.6 again.

None of these things helped. I have noticed this started happening after the last idea12 update I installed. Please send me instructions on how to fix this.

EDIT: tone. -.- (got very frustrated with this)

0

Please sign in to leave a comment.