"Outdated version" yellow bar won't go away

Answered

I'm seeing this happen a lot: I check in a file, close IntelliJ, then open it up again, and see the "yellow bar of Outdated version":

2014-07-03 16_01_00-Clipboard.png

I am absolutely certain that noone else has changed the file since my change.  In fact, if I choose "Update project", no updates come down, because I have literally just updated my project and rebuilt.

I like this warning (when it works), but I'd rather turn it off altogether than have it show up when it's wrong.  Is there a way to turn it off OR to fix it so it only shows up when it should?

(Our VCS is Perforce, if that matters)

4 comments
Comment actions Permalink

Sounds like the VCS indexes may be corrupted. I'd try the following:

  1. File > Invalidate Caches > Invalidate (but do not restart)
  2. Shut down IDEA
  3. Clear IDEA's VCS cache (system/vcs & system/vcsCache, see http://devnet.jetbrains.com/docs/DOC-181 for the system directory location).
  4. Restart IDEA and see if the problem is resolved


If the problem persists, I'd recommend commenting on the bug report http://youtrack.jetbrains.com/issue/IDEA-102564 That ticket discusses the same issue with Perforce. But it sounds like the above steps resolved the issue for the reporter.

1
Comment actions Permalink

That seems to have solved it.  Thanks!

0
Comment actions Permalink

I ran into this same issue with Webstorm & Android Studio, and this suggestion worked for me - thank you!

 

For anyone else coming across this, Mark's link in point 3 no longer works, but this information can now be found at:

https://intellij-support.jetbrains.com/hc/en-us/articles/206544519-Directories-used-by-the-IDE-to-store-settings-caches-plugins-and-logs

 

For me, on a Mac, I just needed to delete the contents of ~/Library/Caches/<Product Name>/vcsCache

0
Comment actions Permalink

One way to fix it is goto Version Control tool window and hit Refresh icon on the Incoming tab. This should remove the yellow bar if your files are in sync with VCS.

0

Please sign in to leave a comment.