Flex: copyDependentFiles=false

Is there a way to avoid copy all non-embedded files to output folder. Flex Builder uses a property called "copyDependentFiles". It seems that I can't set a property for "copyDependentFiles" using a custom compiler config file (my-flex-config.xml) ...

Any suggestion? Thanks!

-Jens


6 comments
Comment actions Permalink

The logic of copying resource files to compiler output directory is not
Flex-specific in IDEA. It is configured in Settings (CtrlAltS) ->
Compiler. Files that matches masks from 'Resource Patterns' field are
copied. But you may exclude some files from copying at
Settings->Compiler->Excludes.

0
Comment actions Permalink

Thanks Alexander. Unfortunately I can't exclude a source folder without throwing errors by IDEA ("Unresolved variable..., Unused import..., etc.").

Any more options?

-Jens

0
Comment actions Permalink

Excluding specific resource files individually.

Or removing one or several file masks from resource patterns. But the
latest seems to be bad solution because it affects all modules and all
your IDEA projects.

0
Comment actions Permalink

Thanks for your trouble! To avoid misunderstandings: Currently all source files and its packages are copied to projects output folder. That means tons of classes located at my source folder are copied to my ouput folder named "bin-debug", but the won't be needed for deploying the app. Unfortunately I can't exclude any folder or files from module settings -> Modules -> myProject -> Sources without any errors within IDEA, because there are part of the source package. BTW: I use a custom compiler config file for compiling the app.

Do I miss something?

-Jens

0
Comment actions Permalink

I suppose you are using IDE builder (i.e. not ant, maven or whatever).
And compiling your IDEA project (Ctrl+F9) copies files that you don't
want to be copied.
Using custom Flex config file or not - it doesn't matter.
You say that all source files are copied. What extensions do they have?
*.as and *.mxml are never copied for me because by default there's no
such resource pattern at Settings->Compiler->Resource Patterns. Default
patterns are:
?.properties;?.xml;?.gif;?.png;?.jpeg;?.jpg;?.html;?.dtd;?.tld;?.ftl;?.js;?.css;?*.swf
Please check that you don't have unnecessary patterns there.

Please do not exclude anything at Project Structure->Modules->Sources.
Exclude I was talking about is at Settings->Compiler->Excludes. But be
careful not to exclude any *.java files in your project as in this case
respective *.class files will not appear in compiler output folder. This
exclude is usually used for folders with resource files that should not
be copied or for individual resource files that match 'resource pattern'
but should not be copied.

0
Comment actions Permalink

I've set up the project again from scratch and now it works! I'm not sure, what the hell did trigger this issue, maybe a conflict with an import of an existing Eclipse project or a parallel opened Flex Builder or just my fault or whatever ...

Thanks again, Alexander!

-Jens

0

Please sign in to leave a comment.