maven_repository cannot be updated

In the latest version, I try to update path var maven_repository to a different location. I can see config xml file path.macros.xml is updated. But when I restart intellij, I still see default path. A little bit later, path.macros.xml is updated to reflect the default path. Is it a bug or what?
I tried to put settings.xml into $userprofile/.m2 with localrepository specified to d:. But it still doesn't work.
I override settings and repo setting in intellij but it seems no effect at all.
Log file of intellij doesn't reveal anything.

3 comments
Comment actions Permalink

I'm new to IntelliJ, and I'm experiencing the exact same problem. Any ideas? I have already overridden the Settings > Maven > "Maven home directory", "User settings", and "Local repository." I have searched high and low for how/where the MAVEN_REPOSITORY path variable is being set with no luck. Just like the OP was experiencing, path.macros.xml gets overridden every time I start IntelliJ. I would use the default location if I could, but I can't. I'm using version 13.0.1.

Thanks in advance for any help.

0
Comment actions Permalink

Hello.

Unfortunately, there is still existent issue with MAVEN_REPOSITORY: http://youtrack.jetbrains.com/issue/IDEA-52486

One of suggested work arounds is there: http://youtrack.jetbrains.com/issue/IDEA-52486#comment=27-677828

Regards,
Alexander.

0
Comment actions Permalink

leave a bug least 3 years, well done.

0

Please sign in to leave a comment.