Artifact has invalid extension issue (JBoss 7, ear artifact)

Hello, All -

I know that when I'm trying to deploy an artifact to JBoss, it seems to require artifacts to have a valid extension even if they are exploded (directories) (e.g., ".war" or ".ear") and to fix this issue, which Intellij flags, I just add (in my case) ".ear" to the end of the Output Directory path and all is well.  My problem is I'd like to leave Settings > Maven > “Import Maven project automatically” checked, but then everytime the pom.xml changes, I have to redo this and its tedious.  Is there a way I can make this "stick"?  Maybe something in the pom that Intellij reads/respects or an Intellij specific thing, or anything else that works.

Thanks in advance,
- Luke

3 comments

Hello Luke,

It's a known issue: http://youtrack.jetbrains.com/issue/IDEA-86484.
Feel free to vote and leave comments.
Please start following it to receive automatic notifications from YouTrack when the issue is updated.
See http://intellij-support.jetbrains.com/entries/23368682 if you are not familiar with YouTrack.

0

Thanks Yaroslav - I just voted for this issue and will encourage my colleagues to vote for it as well.

0

This defect was reported over two years ago!  It needs to be resolved.  So awful to have to go back in to Project Settings and correct the output directory by adding ".war" to the end each time a miniscule change is made to the POM.  Very frustrating!!!

0

Please sign in to leave a comment.