How to build Flex in 9815

I am using flex-mojos to generate my projects and modules, in the last couple EAPs though the Flex facet has dissappeared from my project settings.  I tried invalidating the file caches and re-imported the pom files, but the Flex facet still does not show up.

Did the setup change for configuring Flex projects on how to build?

Thanks.
-Brandon

6 comments
Comment actions Permalink

Hi, Brandon,

What version of flex-mojos do you use?
Please attach the pom file.

Thanks,
Anton Makeev

0
Comment actions Permalink

Hi...
I am using 3.1.0.  Attached is my super pom that pulls in the flex-mojos.  I then have a  child pom that defines my specific repository, custom plug-ins, etc. that defines this flex-mojos pom as its parent.

Not sure if this is related to the pom, but a "Flex" facet is not even an option for me to add to any of my modules in the "Project Structure" view.

Thanks.
-Brandon



Attachment(s):
pom.xml
0
Comment actions Permalink

Check that the Flex Support plugin is emabled in IDEA (Settings->Plugins).

Thanks,
Anton Makeev

0
Comment actions Permalink

There is no Flex plugin listed.  Not in the Installed or Available sections.  There is a flex folder under <IDEA_HOME>/plugins/flex/lib with a jars.

total 2200
drwxr-xr-x  7 bee  admin      238 Apr 22 11:36 .
drwxr-xr-x  3 bee  admin      102 Apr 17 07:01 ..
-rw-r--r--  1 bee  admin  1041434 Apr 17 07:01 FlexSupport.jar
-rw-r--r--  1 bee  admin    46904 Apr 17 07:01 idea-fcsh-fix.jar
-rw-r--r--  1 bee  admin    23318 Apr 17 07:01 idea-fcsh-fix_src.zip
-rw-r--r--  1 bee  admin     6273 Apr 17 07:01 resources_en.jar
drwxr-xr-x  4 bee  admin      136 Apr 22 11:37 test

-brandon

0
Comment actions Permalink

That's strange.
Please try reinstalling IDEA.

0
Comment actions Permalink

Thank you, that was it.  I had re-installed before but I needed to delete the ~/Library/Preferences/Intellij80 folder, I guess it got corrupt some how with a previous EAP.

Thanks!

0

Please sign in to leave a comment.