gradle.properties is being ignored

I need to change the JDK that Gradle uses.  To do so, I created a gradle.properties in the project root with the following line:

org.gradle.java.home=C:/Java/jdk1.6.0_23

If I run gradlew from the command-line ity works perfectly:

C:\Prj\seerdms>gradlew clean-dt

To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: http://gradle.org/docs/1.10/userguide/gradle_daemon.html.

Starting SEER*DMS build using Java 1.6.0_23 (Sun Microsystems Inc. 19.0-b09)

However if I run the same task through IntelliJ, the gradle.properties file is being ignored:

11:43:44 AM: Executing external task 'clean-dt'...

FAILURE: Build failed with an exception.

* Where:

Build file 'C:\Prj\seerdms\build.gradle' line: 4

* What went wrong:

A problem occurred evaluating root project 'seerdms'.

> This project must be built using Java 1.6 but current version is 1.7.0_51 (Oracle Corporation 24.51-b03)

* Try:

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

Is there something I'm missing?

1 comment
Comment actions Permalink

there is an open issue for the bug, you can watch it at http://youtrack.jetbrains.com/issue/IDEA-122158

0

Please sign in to leave a comment.