Flex: All references to external libraries marked red in editor

In builds 9805 and 9815 all references to external libraries (non Flex SDK) are marked red in the editors - compiling/debugging via IDE settings works ok. This is a real disaster because next week I will be trying to convince the Flex department to purchase 10 IDEA licenses (instead of Powerflasher FDT). Can this be fixed soon or do I overlook something?

Thanks and Regards,
Peter

4 comments
Comment actions Permalink

Please, try removing IDEA system caches and restart. Please, post again
if the problem persists.

Peter Jacobsen wrote:

In builds 9805 and 9815 all references to external libraries (non Flex SDK) are marked red in the editors - compiling/debugging via IDE settings works ok. This is a real disaster because next week I will be trying to convince the Flex department to purchase 10 IDEA licenses (instead of Powerflasher
FDT). Can this be fixed soon or do I overlook something?

Thanks and Regards,
Peter

---
Original message URL: http://www.jetbrains.net/devnet/message/5236072#5236072



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

Clearing the cache did not solve the problem - but:
When I add all external libraries in "Project Settings->Dependencies->Add->Module Library...->Attach Classes" manually (instead of using the parent directory) it works. This used to work fine before. Usually I just threw new SWCs into the configured directory an IDEA picked it up automatically. Filed a JIRA ticket http://www.jetbrains.net/jira/browse/IDEA-22676

Thanks,
Peter

0
Comment actions Permalink

Please, setup namespace / manifest location in Flex configuration as work around

0
Comment actions Permalink

Thanks for the suggestion!

Regards,
Peter

0

Please sign in to leave a comment.