Can't Type in 9144 + Linux

I am using Linux Mint (based on Ubuntu 8.04) with the nVidia Drivers and Compiz
I have the following in .bashrc to get around some painting issues
#Workaround re-paint issues with Java and Compiz
export AWT_TOOLKIT="MToolkit"
#JDK
export JDK_HOME=/usr/lib/jvm/java-6-sun-1.6.0.07

Most things worked fine with #8940.
However, with #9144 I can't type in any of the editors and double clicking on files wont open them (although dragging them to the editor pane or right-click open does work)

Anyone else have this issue?

15 comments
Comment actions Permalink

I haven't had this issue exactly as you describe it but I've experienced some similar behavior. I'm running 9144 on Windows and occasionally the editor won't respond to key strokes.

I've typically seen this happen when I have some bad syntax that is highlighted red. For a few seconds the editor just doesn't respond to anything and all the sudden it will work again.

I've also been having issues with cut and paste. After I highlight some text and hit ctrl-c to copy it doesn't always take affect and when I go to paste it will paste what was in my clipboard previously. If I wait a second or two before ctrl-c it seems to be ok. Perhaps some of the inspections are getting in the way?

0
Comment actions Permalink

having the same problems in Windows.

Edited by: Thai Dang Vu on Nov 20, 2008 7:00 PM

0
Comment actions Permalink

Same here w/build 9144 on Mac OS-X.

at first i thought it was a garbage collection pause.

for me it has been mostly related to trying to use the delete key and red code... maybe a coincidence though because i haven't been able to make it repeatable.

to get it to come back i have to select text elsewhere with the mouse and then click back to where i was editing.


very strange.

0
Comment actions Permalink

I had the same issue multiple times. Backspace would stop responding. But the character key strokes would be fine.

0
Comment actions Permalink

Wow, I actually believed I have problems with my keyboard on this.
Happens to me with 9144 on Windows XP quite regularly, unfortunately.
And it happened exactly as described here: backspace does not work, but typing does.

In addition, when it happens, usually the UP / DOWN keys scrolls the editor instead of moving the cursor.

I will try to see if there is a way to reproduce it consistently (like "it always happens when that and that").


Has anyone reported this yet?
I consider it to be a major issue because it happens pretty often and it's hell when it does.

0
Comment actions Permalink

Ditto (with 9144) - I hit this yesterday. I'm going to run 9158 and see if the issue is still here - has anyone logged this issue in JIRA yet?

0
Comment actions Permalink

As far as I can tell, the link you posted isn't applicable to this issue - Ive been using 9158 today, and the issue of the editor locking up (key presses not being recognized/responded to) is still present

0
Comment actions Permalink

it's still in 95xx builds on Mac OS X

0
Comment actions Permalink

Nope, I just got this with 9158.

I reported the issue:
http://www.jetbrains.net/jira/browse/IDEA-20849

Better to have dupes than no report at all...

0
Comment actions Permalink

I still get this in 9757 when using linux.
It happens almost 100% of the time. i.e. at some point during my session (unless it is very brief) the IDE will stop responding to keyboard input and I will have to restart.
It doesn't happen at all when I am using IDEA in Windows Vista.

Are any of the IDEA developers running Linux?
The only other thing I can think of is to take a CPU snapshot. However, that could end up being huge as it might be 20 minutes before the issue occurs.

0
Comment actions Permalink

Hello opticyclic,

Please file a JIRA issue with the contents of all your system/log/threadDumps-xxx
directories attached.

I still get this in 9757 when using linux.

It happens almost 100% of the time. i.e. at some point during my
session (unless it is very brief) the IDE will stop responding to
keyboard input and I will have to restart.

It doesn't happen at all when I am using IDEA in Windows Vista.

Are any of the IDEA developers running Linux?
The only other thing I can think of is to take a CPU snapshot.
However, that could end up being huge as it might be 20 minutes before
the issue occurs.
---
Original message URL:
http://www.jetbrains.net/devnet/message/5233588#5233588

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I'm not sure if that will help.
The problem has just occurred, however, the latest thread dump directory is empty.
~/.IntelliJIdea8x/system/log/threadDumps-20090312-091434-9757

What happened was, I was swapping back and forth between IDEA, Nautilus and the terminal as I was testing some features on a server then IDEA stopped accepting keyboard input so I just shut it down with the Close Window button.
Do I have to do something else to generate a thread dump?

0
Comment actions Permalink

Just for reference: looks like http://www.jetbrains.net/jira/browse/IDEADEV-2359 (if this is really the single issue, not several ones).

Alexander.

0
Comment actions Permalink

I don't want to jump the gun, but I had one session without this occurring after following the advice in that thread.
Specifically, http://www.jetbrains.net/jira/browse/IDEADEV-2359#action_198362
i.e. Not installing via apt, but via unpacking the JDK and setting JAVA_HOME manually

0

Please sign in to leave a comment.