Find in path behaviour change

Hi,

I recently moved from version 11 to version 13, and one thing I've run across which is a pretty big loss of functionality (I believe) is that Find in Path used to enable you to search any arbitrary path and find a string.  Now, however, it will only find items in paths which are part of the project.
For example, given this set up:

/src/MyProj
/src/SomeOtherProj

In Intellij 11 (and earlier, I've been doing this a long time), if I were working on MyProj, I could do Find in Path, and if I selected /src as my path, it would find the string in files in both MyProj and SomeOtherProj.  However, in Intellij 13, it seems to only find the string in files in MyProj, even though I know the string is also in files in SomeOtherProj.

Is there an option to restore the previous behaviour?  It was *hugely* useful to be able to search some other files without having to add them to my project, or to open up 4 or 5 other projects in order to be able to search through their various files.  Given that I also have the option to restrict to things like "Whole Project" or "Project Files", etc., it doesn't seem like enabling search of other arbitrary directories is preventing someone from searching just the files they want to search.

Thanks very much for any help!

3 comments

Hello.

Seems to work for me in IDEA 13. I have called Find in Path on the project root node in Project tool window. Then changed Directory from C:\path-to\my-projects\current-project to C:\path-to\my-projects
Searched for something common (I tried "public" keyword). It gives me all "publics" from all my projects under that path.

Can it be that you are searching for an entry really used only in one project?

Regards,
Alexander.

0

That's...interesting.  I have IDEA 13.1.1 Community Edition running under 1.7.0_40, and it very definitely is not finding file contents in anything but the current open project.  Very frustrating.  I have a folder with a dozen or so projects in it, and while working one, I'll want to refer to something in another, and this used to be a very quick way of doing so.  I wonder why it's not working.  :/

0

Tried the latest "micro-release" 13.1.3 (build 135.909), Community Edition. Still works for me.

You can update to 13.1.3, however I'm not sure that this is the key.

Also try main menu / Files / Invalidate Caches / Invalidate and Restart.

Also you can post here a screenshot of Find in Path dialog, before you hit Enter: maybe some not evident setting interferes in.

Regards,
Alexander.

0

Please sign in to leave a comment.