Pure Actionscript Project, no trace messages and Flash Debugger does not connect. What did I miss?

Hi, I've been using IntelliJ to build AIR projects and the trace and debugger work just fine.
Today I have created a Web Project using Actionscript.
The sample project runs in the Flash Player.
However, a simple trace("Hello World"); doesn't show up in the console.
I also tried running the Debugger and it doesn't ever connect and the trace doesn't show up.

For now I am using MonsterDebugger but I don't understand what I am missing.
I tried using different SDK versions and they all react the same way.

Maybe there is a setting I missed?
But I don't remember having to set up anything special in FlashBuilder or FDT to get trace to work...

I would appreciate any help on this.
Thanks
- Patrick

3 comments
Comment actions Permalink

Most likely you have non-debugger Flash Player version installed. To check it right click any running Flash app and see if 'Show redraw regions' option is there in the context menu - it is there in debugger version only.

0
Comment actions Permalink

Thanks for the reply Alexander,

so I've fixed one issue.
I created a configuration that points to the latest Flash Player Debugger.
I can connect and debug...perfect.

The odd thing is that I can only see trace messages when I use the Debugger.
Trace messages do not show in the Console/Event log when I'm targeting the regular Flash Player.

Is this the expected behavior for IntelliJ with Flash? That trace messages ONLY show in the Debugger?

Thanks
- Patrick

0
Comment actions Permalink

Yes, that's expected. In Run mode IDE doesn't control the process and doesn't show any kind of console.

0

Please sign in to leave a comment.