Find usages in [file|project] does not work for libraries

Windows 7 with IJ Ultimate 13.1.2 (just one minor minor release back from latest).

Repeatable failure mode:  
   (a) navigate to a project library class containing source code. E.g. i went to akka.actor.Actor
   (a)  select a class, method, or attribute
   (b)  Edit | Find | Find Usages in File   .   
    or  Edit Find | Find Usages in Project

Nothing happens.

Note:  the above works fine against project files.

3 comments

Hello.

Can't reproduce in 13.1.3 (but I'm not sure the version is the reason). Got a Maven module with dependency to javaee, so javaee classes are in libraries. Downloaded sources. Opened HttpServlet. Selected METHOD_DELETE private constant. Searched in file - found an entry.

Anything suspiciously different to your case?

Regards,
Alexander.

0

No, I was searching akka.actor classes and methods.  Tried a few of them. Consistent behavior: library entries not found.

Only difference: my project is sbt based.

0

Stephen, I can't reproduce the problem as well. Tried IDEA 13.1.3, sbt project with akka dependency.
Could you please check if it occurs in any other projects or in new sbt projects?

Thank you,
Victoria

0

Please sign in to leave a comment.