How can I cange font in editor?

Sorry for my bad english, I'm russian

I have IntelliJ IDEA 8.0.1 on Linux Fedora Core 10 x86_64, with latest x32 Sun JDK.

Also I have a couple of TTF fonts what i'd like to see in Editor window.
All this fonts installed in "/usr/share/fonts" and "~/.fonts" directories.

But in the "settings -> editor -> colors&fonts -> font" dialog i can see only:

URW Pallatio,
URW Gothic,
URW Bookman L,
Serif,
Sans Serif,
Nimbus Roman n9,
Nimbus Mono,
Monospaced,
Lucida Sans Typewriter,
Lucida Sans,
Lucida Bright,
Dialog Input
Dialog
Century Schoolbook L
AR PL Uming (CN, HK,TW, TW MBE)
Courier

I put my fonts in $JDK_HOME/jre/lib/ too and run ttmkfdir to generate .scale, added font name directly to color settings file, but without success.

How can I solve this problem?

wbr, Oleg Chiruhin

Please sign in to leave a comment.