#9618 memory usage with Flex

This problem goes for #9618 and the #9572 where I've tested this behavior.  I've got a large flex app and when I open some of my mxml files I see the memory usage shoot up to my allowed maximum.  Upping IntelliJ's mx value to 500M only delays this problem.  I look at my CPU usage (quad-core Xeon) and observe what appears to be a single thread that is hogging whatever core it's on.  It jumps cores now & then.  IntelliJ is basically unusable at this point.  The colored square at the top-right of the editor is unfilled and never becomes filled (green/yellow/red).

FWIW I sent a performance report and it's named perf_9618_dsmiley_20090105-105455

I'm experimenting with using JDK 1.6 but that hasn't helped.

~ David Smiley

4 comments
Comment actions Permalink

I made the same observation with fairly complex MXML files - IDEA seems to loop at some point, never getting finished with code inspection. My memory settings are -Xms256m -Xmx1024m, running OS-X 10.5.6 with the latest JDK 1.5. Hardware is an 8-Core Mac with 14GB of RAM. As David mentioned - upping memory only delays the problem.

Another thing: every now and then I clear the IDEA cache and when I reopen my Flex project (ca. 200 classes), library (SWCs) and JavaScript indexing hogs memory like crazy (up to 600MB). Then I usually close the project, shut down IDEA and start fresh with a memory consumption of around 100MB after the project is open - which I consider OK.

Regards,
Peter Jacobsen

0
Comment actions Permalink

Thankfully I managed to successfully downgrade to 8.0.1 but it took some fenangling to get my large flex app to compile.

0
Comment actions Permalink

I had the same problems you describe until I upgraded my version of the Flex SDK. The startup time and memory consumption was reduced a LOT after that.

Hope that helps!

0
Comment actions Permalink

Ideed; I think you're right.  I moved from the 3.1 to 3.2 SDK and it doesn't seem to be a problem for me anymore.  I'm still keeping my memory allocation high just in case.  I'm back to #9618 now.

0

Please sign in to leave a comment.