is colors in injected language syntax highlighting configurable?

Answered

Has anyone noticed that with a dark color background , injected language syntax highlighting (e.g., javascript in HTML, JSNI in gwt java code) will not have the same background color as the current file, but have a grey/white-ish background, causing text to be unreadable. I tried editing the config/colors/*.xml files, but to no avail. And there doesnt seem to be an option in settings to change the background color of injected language highlighting.

Perhaps i m just missing something? see the screenshot below, from line 88.

screenshot.JPG

5 comments
Comment actions Permalink

Hello Chii,

Settings | Editor | Colors and Fonts | General | Injected language fragment

Has anyone noticed that with a dark color background , injected
language syntax highlighting (e.g., javascript in HTML, JSNI in gwt
java code) will not have the same background color as the current
file, but have a grey/white-ish background, causing text to be
unreadable. I tried editing the config/

colors/*.xml files, but to no avail. And there doesnt seem to be an
option in settings to change the background color of injected language
highlighting.

Perhaps i m just missing something? see the screenshot below, from
line 88.

!http://www.jetbrains.net/devnet/servlet/JiveServlet/downloadImage/101
0/screenshot.JPG|alt=screenshot.JPG|width=450|class=jive-image-thumbna
il jive-image

---
Original message URL:
http://www.jetbrains.net/devnet/message/5229250#5229250

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Wow, never noticed that! THanks!

0
Comment actions Permalink

This is no longer the case with the current version of WebStorm. Where can I edit code injection background colors?

0
Comment actions Permalink

The color can be changed in `Settings | Editor | Color Scheme | General | Injected language fragment`

0
Comment actions Permalink

The issue was for me that the inspections in Preferences > Editor > Inspections > "Sql dialect detection" was checked and it caused a warning background to appear, overriding any changes from the background color with injected language fragment.  So in case you try to change the background color and that still doesn't work.  Check your inspection settings, either register a dialect with it or turn off that inspection.

0

Please sign in to leave a comment.