"Find Usages" change with 13.1.2 or accidental settings change?

For some reason, the default "Find Usages" now returns text occurences by default for me. I noticed this around the time I took an update earlier this week. Is it possible to disable this so that I don't have to go through "Find Usages Settings" dialog? Text occurences are basically never relevant for me. If I wanted to find text occurences, I would just find text in files which provides much better filtering capabilities.

build.txt contains IU-135.690
Using Scala plugin 0.35.654 but doubt this is relevant

Thanks
Dave

5 comments
Comment actions Permalink

Has no one else noticed that "Find Usages" now returns text usages and puts them at the top of the search results? For me, this makes a frequently used action less helpful. Going through the "Find Usages Settings" and unchecking "Search for text occurrences" requires a dialog and mouse click.

If no one else has this behavior, I assume what I'm seeing must be an accidental settings change. I haven't been able to find this setting though.

0
Comment actions Permalink

It sounds like you have turned on the "Search for text occurrences" option. You can change that in the "Find Usages Settings" dialog. Open it either via Ctrl +Alt +Shift +F7 or via the menu Edit > Find > Find Usage Settings. Find Usage settings are set via a pop-up dialog rather than in the IDE Settings since it is something users may want to tweak frequently.

0
Comment actions Permalink

Thank you for your response. I tried this and my choice does not stick, and I'm not sure that I would expect this to change the default behavior of "Find Usages." After performing a search with "Search for text occurences" unchecked, I still get text occurences returned when I perform normal "Find Usages."

As I said, I wouldn't expect this to change the default behavior of "Find Usages" unless there was some additional "make default" checkbox added to this dialog. Assume 99% of my "Find Usages" searches were without text occurences, but then 1% of the time I want to go through the dialog to search for text occurences as well (e.g. http request routes across server code, routes configuration, js).

Was this redesigned in 13.1.2?

0
Comment actions Permalink

It appears it was (purposefully) changed in IDEA v13. See http://youtrack.jetbrains.com/issue/IDEA-120751

0
Comment actions Permalink

Good find. Thanks. This must have changed in 13.1.2. Coworkers still on 13.1.1 do not have same behavior I'm seeing in 13.1.2.

In case anyone else finds this, I have opened an issue referencing the original to suggest that the behavior of "Find Usages" be configurable.

http://youtrack.jetbrains.com/issue/IDEA-124711

0

Please sign in to leave a comment.