Can't assign Ant targets to Quick Lists any more?

I can no longer assign ant targets to my quick list.
I go into the options and select "Quick Lists", but the "Ant Targets" node is empty.
I definitely have Ant files setup in IDEA, and I can run those targets by double-clicking them in the Ant window.

But. I need fast access to the targets - I hate having to mouse around to run simple Ant targets.

This is happening in 8887 and 8895. Last version I can be sure it was working in was 8733.

Edited by: Shorn Tolley on Nov 3, 2008 10:18 AM

3 comments
Comment actions Permalink

This may have been a temporary thing as they were reworking the settings dialog. But it is there for me in 8995. See attached screenshot.



Attachment(s):
quicklist_settings.png
0
Comment actions Permalink

I'm running 8995 now, but still the same problem.
I tried removing one of my Ant files and re-adding it - no good, still doesn't show any ant targets.
When I installed this version, I blew away the system/index and cache directories.

0
Comment actions Permalink

Hello Shorn,

I can no longer assign ant targets to my quick list.

I go into the options and select "Quick Lists", but the "Ant Targets"
node is empty.

I definitely have Ant files setup in IDEA, and I can run those targets
by double-clicking them in the Ant window.

But. I need fast access to the targets I hate having to mouse
around to run simple Ant targets.


This is fixed in build 9011. Thank you for the report.

Just notice that initially, on opening a project IDEA does not configure
project ant files (for better performance). But if you trigger this process
(e.g. open Ant Build window, or open main menu / Build) then after that ant
targets will be available in quick lists.

Alexander.


0

Please sign in to leave a comment.