How to disable automatic web-facet detection

It's not just annoying but also changes things silently even when I
discarded the proposed changes.

Tom

7 comments
Comment actions Permalink

Project Settings -> "Facets" item -> "Web" node -> "Auto-detection" tab (in Diana).

It's not just annoying but also changes things silently even when I
discarded the proposed changes.

Tom



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Nikolai

This feature is the most annoying and frustrating feature I have ever seen introduced in Idea.

Diana is the code name of version 8.

I really need to be able to turn this off in version 7. Because of the plugin changes to 8 I will probably not upgrade to it until the final gets released.

Can we have a workaround in the next version of 7 for this problem? Even if it is a system property to simply turn off all facets.

0
Comment actions Permalink

Project Settings -> "Facets" item -> "Web" node -> "Auto-detection" tab
(in Diana).


Sorry, because of Greg's response I found now your answer. Where is the
setting in Selena?

Tom

0
Comment actions Permalink

I'm guessing the silence received when asking how to disable the facet detection in 7 means there is no way to do this?

Unfortunate. I've added all the Facets it detects and the cog is still blinking at me even though there are no new facets.
Would be great if there could be 7.0.5 which adds the ability to disable this.

0
Comment actions Permalink

In IDEA 7.0.4 you can append line
idea.facet.autodetection.disabled=web
to /bin/idea.properties file in order to disable auto-detection of Web facets. >> Project Settings -> "Facets" item -> "Web" node -> "Auto-detection" >>]]> tab (in Diana).


Sorry, because of Greg's response I found now your answer. Where is the
setting in Selena?

Tom



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

hi - i hope it's ok to use this thread for my problem:

When ever i open my project in intellij IDEA 7.0.4 i get a pop-up telling me that "0 facets detected...".
That i could ignore..

but also the facet detected icon is blinking. And it just won't stop. - If i double click it i get a "new facets detected" dialogue.. with an empty content pane. I have tried all three buttons it offers: Accept, Postpone and Edit Settings

Nothing helps, it just keeps blinking.

And "Edit Settings..." does show the project settings.. and nothing concerning any facets, as far as i can tell.

I also tried adding
idea.facet.autodetection.disabled=web
to /bin/idea.properties

It does not help. (restarting intellij and/or reopening the project after doing that)

Please help me get rid of the blinking and very annoying icon.

Thank you and greetings form Ulm,
JP

Edited by: jp-ulm on Nov 3, 2008 6:54 PM

i found a fix to this (in my case) - i opened my projects .ipr file (thank god it's xml :) ) and looked for anything about facets - i found:

... ]]>

And just removed it completely.

Next Startup i got a "3 facets found" message, deselected them and accepted. - Now the problem is gone.

Thanks for reading,

-JP

Edited by: jp-ulm on Nov 3, 2008 7:08 PM

0
Comment actions Permalink

Try to clean the <idea.system.path>/facets directory.

hi - i hope it's ok to use this thread for my problem:

When ever i open my project in intellij IDEA 7.0.4 i get a pop-up telling me that "0 facets detected...".
That i could ignore..

but also the facet detected icon is blinking. And it just won't stop. - If i double click it i get a "new facets detected" dialogue.. without ANY content. - And i have tried all three buttons it offers Accept, Postpone and Edit Settings...

Nothing helps, it just keeps blinking.

And "Edit Settings..." does show the project settings.. and nothing concerning any facets, as far as i can tell.

I also tried adding
idea.facet.autodetection.disabled=web
to /bin/idea.properties

It does not help. (restarting intellij and/or reopening the project after doing that)

Please help me get rid of the blinking and very annoying icon.

Thank you and greetings form Ulm,
JP



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Please sign in to leave a comment.