8890: problem opening files with Ctrl+N

Press Ctrl+N, type in the initcaps version of my class (eg. XDL for XmlDataLoder), get exception, can't open file.

CtrlShiftN works, but then there's no syntax highlighting in the file.

Anyone else getting this?

6 comments
Comment actions Permalink

Hello Shorn,

Press Ctrl+N, type in the initcaps version of my class (eg. XDL for
XmlDataLoder), get exception, can't open file.

CtrlShiftN works, but then there's no syntax highlighting in the
file.

Anyone else getting this?


Please post the exception you're getting.

Most likely the problem can be fixed by clearing the system/index directory
and restarting IDEA.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I've noticed that IDEA treats .java files as text files once they reach a certain size threshold. I think it is around 10,000 lines.

(Don't worry I'm not writing 10000+ line java files, but a code generator I use does.)

0
Comment actions Permalink

I can't check on the details right now, but that threshold is configurable in the Settings.

... I think I may have been wrong about that. I'm not sure where I got the idea, but right now, I can't find any configuration setting that relates to the limit beyond which inspections and whatnot are no longer applied.


Randall Schulz

Edited by: Randall Schulz on Oct 16, 2008 1:12 PM

0
Comment actions Permalink

Will try, but I've had to swap back to 8733 to get some work done.

When you say "system/index" directory, is there a particular set of directories you folks normally clear?
Or are you saying I should just blow away the whole ]]>/.IntellijIdea80 directory?

0
Comment actions Permalink

Hello Shorn,

Will try, but I've had to swap back to 8733 to get some work done.

When you say "system/index" directory, is there a particular set of
directories you folks normally clear?

Or are you saying I should just blow away the whole
<home>/.IntellijIdea80 directory?


When I say "system/index", I mean specifically the ]]>/.IntelliJIdea80/system/index
directory.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hi Dmitry,

I tried to reproduce the problem, but could not get it to come up.
As you've implied, it must have just been some problem in the index files, and the process of swapping back to 8733 and then forward to 8890 must have reset it somewhere along the line.

I will make sure to make a note of the exception if it happends again (though I did submit it using the error reporting tool).

FYI: without that error, the 8890 build seems much more stable and usable for me than other recent builds.

Thanks,
Shorn.

0

Please sign in to leave a comment.