IntelliJ 13.0.2, Maven, and Tomcat 7 JSP hotswap

I'm having issues with hot swapping .jsp,.js, .html, and .css files when developing with intelliJ and deploying to tomcat. (The issue being it doesn't work for me)

Relevant version info:
IntelliJ: 13.0.2
Maven: 3.1.1
JDK: 1.7.0_45
Tomcat: 7.0.40

I've googled of course, and seen several blog posts regarding the same issue, and I've still been unsuccessful at acheiving the behavior I'm looking for.

Here's what I *can* do.

Build the war/war: exploded artifacts.
Deploy them to Tomcat
Re-deploy them to tomcat (a la Ctrl-F10)

What I can't do is:
Make a change to a .jsp, refresh my browser window, and have the change show up.

I've got "On update action" set to "Redeploy" (which is why Ctrl-F10 works so well)

"On Frame deactivation" is set to "Update Resources"..... Now when I make a change to a file (say index.jsp), and click somewhere else, it does give me the notification the files was changed. Going to check in target/myapp/index.jsp, it shows the proper update time, and the content of the file is sync'ed with what is in the IDE.

Hitting the page via the browser, does not, however, show an updated file. This holds true for other static resources as well.

It sounds to me like I've overlooked some form of Tomcat configuration flag, but I'm not sure. Does it sound like I'm going down the right path, or have I done something majorly wrong. I've deployed exploded to weblogic and glassfish just fine, but tomcat doesn't really seem to feel it. :(

Thanks for reading.

Comment actions Permalink

As an addendum, I can deploy the same application, in (basically) the same manner, to Glassfish 4, and everything works exactly as I would expect.

I really think I'm missing some magical "aha!" configuration setting in tomcat. Any ideas as to what it could be?

Comment actions Permalink

Also works as expected in WebLogic. What am I doing wrong with Tomcat?


Please sign in to leave a comment.