JavaScript autocomplete excessively agressive

I'm working with JavaScript in IDEA ultimate 13.0.2 and it's aggressive in completing where it shouldn't.

Here is my specific problem. I want to type the following code:

var x = {
  prop: "123"
}


What happens to me is that after I type the colon of prop, it immediately pops up autocomplete, even though my style settings say space after colon. I'm sure I must be missing something or some setting somewhere. If I type "prop:" followed by a space, I get the following:

var x = {
  prop:break
}


Because when auto-completing nothing, the break keyword is the first suggestion and my space key chooses that selection.

This is extremely annoying, as every time I type a colon in javascript I have to type colon, escape, space. I've gotten used to it over the past few months but it seems crazy that IDEA was meant to be this way so there must be a solution.

4 comments
Comment actions Permalink

Is there a setting for this, or is this by design? It just seems like there is something simple I'm missing or have misconfigured...

0
Comment actions Permalink

I found out from http://youtrack.jetbrains.com/issue/WEB-10314 that disabling the setting "insert selected variant by typing dot, space, etc." will "fix" this issue. The real issue to me seems that the JavaScript editor autopopup the code completion immediately after colon and for statements like "var i". This makes the "insert selected variant by typing dot, space, etc." feature practically unusable with the JavaScript editor.

0
Comment actions Permalink

still have this issue in 2019. Disabling the auto insert works but doing any JS development with this feature is impossible since constructing objects/json is integral.

0
Comment actions Permalink

@Achaldyshev, please provide more details on the issue you encounter. There have been many changes since 2014. Also, what IDE version do you use?

0

Please sign in to leave a comment.