Problem with JDK in IDEA

After installing build #7656 today I got some problems. I'm not sure it acctually is connected to the upgrade but still the problem is very annoying. Suddenly I wasn't able to compile anymore with an error text with something about javac not a valid Win32 Application.

By now I pretty much tried everything from setting up a new project to completely remove and reinstall the IDEA. Now when I try to add the JDK on the freshly installed IDE I get this error:

"Probably JDK installed in 'C:/bea/jdk142_08' is corrupt"

This is all very strange because there are nothing wrong with the javac.exe file or the JDK installation since it works just fine under eclipse and Ant. What could be wrong? What does IDEA use to determine and launch the javac? I'm running out of ideas here.

Regards H

1 comment
Comment actions Permalink

I saw a similar problem with version 7.0.4, build 7941, on a mac running Tiger (not sure which version). When configuring the JDK, the one suggested was in /System/Library/Frameworks/JavaVM.framework/Versions/ (choice here). The dir CurrentJDK is a symlink to the 1.5 version but we tried that, Current, 1.5, 1.5.0 anyway. Anything we tried in that directory produced a popup titled "cannot detect jdk version", containing a note much like, "probably the JDK in /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Home is corrupt". I tried running IDEA from the command line and gave it that exact path for its JAVA_HOME variable, which worked fine to run the app. Also the user never made any changes to that directory, it's a clean Apple version of Java.

I was able to get around this by selecting, instead of /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Home , /System/Library/Frameworks/JavaVM.framework/Home . The odd thing is, that is just another symlink to /System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK/Home.

0

Please sign in to leave a comment.