SVN on the Mac doesn't seem to work anymore (since Selena-7878)

SVN on the Mac doesn't seem to work anymore in recent 7.0.4. RCs.
Every request send via IntelliJ results in he following message being displayed.

"Error:svn: REPORT of '/svn/SD/!svn/vcc/default': 400 Bad Request"


Going back to Selena-7878 and everything works fine.

9 comments
Comment actions Permalink

Hello Wolf,

Have you tried build 7825? Do you access the repository through HTTPS? Do
you use client certificates for accessing the repository?

SVN on the Mac doesn't seem to work anymore in recent 7.0.4. RCs.
Every request send via IntelliJ results in he following message being
displayed.

"Error:svn: REPORT of '/svn/SD/!svn/vcc/default': 400 Bad Request"

Going back to Selena-7878 and everything works fine.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Yes, I did try 7925 and no, I'm not using HTTPS - just http to a local server.

0
Comment actions Permalink

Hello Wolf,

actually it may have been the "proxy problem": (please see here, for instance)
http://live.gnome.org/SubversionFAQ#head-5af80feb3c387898cbbfba094851599043dd571d

so probably you should configure proxy in Idea for subversion to know it is talking trough proxy.

For proxy configuration details, please look here: http://intellij.net/forums/thread.jspa?threadID=276433&tstart=0
(we have had the bug recently fixed in 7925)

0
Comment actions Permalink

I did try this with the last two releases (incl. 7925) but it didn't make a difference.
Again, in 7878, SVN works. So for now, I'm stuck with that and hopefully you will get it fixed before 7.0.4 get released.
Thanks
Wolf

0
Comment actions Permalink

Hello Wolf,

let me understand it better

1. Do you indeed have proxy between you and Subversion server? and do you need Subversion requests to go through a proxy?
2. Do you have any settings in Subversion "servers" file?
3. Have you configured proxy through Settings | IDE Settings | Plugins | HTTP Proxy Server ?
4. Have you tried to access your Subversion server with other clients? like Tortoise SVN or "native" svn?

I expected that for proxy configuration with 7925, one can set proxy settings in
Settings | IDE Settings | Plugins | HTTP Proxy Server,
clear (or just backup somewhere) Subversion 'servers' file and have Idea subversion integration taking proxy settings from '.. Plugins | HTTP Proxy Server '

I tested this variant and it definitely works here at our configuration.

Edited by: Irina Chernushina (JetBrains) on Jul 25, 2008 3:40 PM

0
Comment actions Permalink

While we have a proxy here, the svn server is not behind the proxy.
However, since I ran into the described problem, I tried to configure IntelliJ to use it anyways - just to see if that would make it work.
However, nothing seems to work - I can still use svn through intelliJ with 7878, the Java SVN client: SynroSVN works for me as does the command line of course.

0
Comment actions Permalink

See my last comments on IDEADEV-28522

0
Comment actions Permalink

Even with the 7.0.4 release. This doens't work for me anymore.
I'm getting this error message:
Error:svn: REPORT of '/svn/SD/!svn/vcc/default': 400 Bad Request (http://denali)

I never found the SVN integration to be really great in IntelliJ and always had SVNbar installed (which doesn't work for me in 7.0.4 on the Mac anymore either). For me it's now It's either going back to Selena #7878 or making the final jump to netbeans.

0
Comment actions Permalink

FWIW (not much, I know)... I'm using 7938 on a Mac with subversion and the SVN-Bar plug in and they all work just fine. I'm using svn+ssh, http, and https protocols (different projects).

The only problem I have is when I set something up in ~/.ssh/config -- but that is expected as the pure Java subversion client doesn't use the command line svn.

0

Please sign in to leave a comment.