How to make Javadoc @link autocompleter avoid full package names?

I think some autocomplete behavior for writing Javadoc has changed for me recently. I'm using IDEA 13.0.1, and have been using IDEA since version 12.

Suppose I'm writing a Java class, and I have imported some classes, such as this:

import java.util.HashMap;

Now I'm in the middle of writing some Javadoc in my class, and I start typing this:

{@link hashm

At this point the autocompleter suggests java.util.HashMap, and I choose it.

I seem to recall that sometime in the past (either an earlier IDEA version or different config), as soon as I chose that class, it would result in text like this:

{@link HashMap}

But now it produces this:

{@link java.util.HashMap}

which is correct but verbose. The same thing happens when I link to other classes that shouldn't need to be fully qualified with package names -- for example, other classes in the same package as the class I'm working on.

Is there some setting that can make IDEA generate the more concise class name when appropriate?

Thanks!

Please sign in to leave a comment.