Set Scala Home

I needed to do something quickly in Scala so I installed the latest Scala version and the latest Intellij version.

I installed Scala 2.10.3 in in E:\dev\scala and then set-up Intellij 13.0.1. I created a new Scala project and in the setting "Set Scala Home" the following was already filled in by Intellij: "E:\dev\scala\bin" and then right under it there was a message that said "not valid scala home". So I changed the setting to "E\dev\scala" and then Intellij produced another message "missing files scala-library-src.jar, scala-swing-src.jar, scala-actors-src.jar. etc. So if it is not what Intellij set it to or it is not what it really is (E\dev\scala) then what does Intellij want from that setting? Thanks for your help.

2 comments
Comment actions Permalink

Sorry for the typo... that was meant to be E:\dev\scala (not E\dev\scala)

0
Comment actions Permalink

Turned out is was the .msi version of Scala that does not work (Windows installer). As soon as I downloaded the .zip version all worked perfectly first time.

0

Please sign in to leave a comment.