I can't get Live Edit to work

I have anew job and i've installed IntelliJ IDEA 12.1.6 and i'm trying to get Live Edit to work for a few hours, but I can't get it to work.

- I've succesfully installed the Live Edit plugin in IntelliJ
- I've succesfully installed the JB extension in Chrome (31.0)
- It does connect to IntelliJ. If I hover over the JB-icon in my chrome, it says it's "connected to IntelliJ IDEA 12.1.6"
- If I open up the generated background page for the Chrome extension, it does look like it's working. For every change I make in my CSS file it receives data.
- The yellow bar with "JetBrains Chrome Extension is debugging this tab" is NOT showing.
- Nothing changes in my page (only after save + refresh in the browser)

The file i'm working on is located in a mapped network drive (development server located somewhere else) and the site is viewed online (not via a localhost). Does the Live Edit plugin only work with a local development setup and not in remote setups?

2 comments
Comment actions Permalink

>> Live Edit plugin only work with a local development setup and not in remote setups?
It seems your page is not detected as inspectable. Please add deployment server (type: in-place, it is part of plugin "Remote hosts") and specify root page URL as deployment server URL.

Please note: Since IDEA 13 LiveEdit works as part of JavaScript debug session only, so, you can try to use IDEA 13 and just create JS Debug run configuration.

0
Comment actions Permalink

That solved it! Thans a lot!

Atmy previous job I developed on a local machine, but now it's on a remote host. That was indeed the difference.

The steps I took to get it to work (for future reference):
- Go to plugins in settings
- Enable the "Remote Hosts Access" plugin
- Go to "tools" > "deployments" > "configuration..."
- Add a new server. Type "In Place".
- Enter the root URL in "Web server root URL" in the tab "connection"
- In the tab "Mappings" enter the local path and the web path.
- Check if the "Project URL" is correct.
- Click Apply or OK.

0

Please sign in to leave a comment.