Disable automatic Refreshing VCS History

Hello,  is there any way how to disable this feature?  The problem is that after i do commit changes to CVS, the 'rlog' command is running automatically for the whole project. And this is something i don't need and don't want. I had to turn it on somehow when changing some ide settings because rlog output started appearing in cvs output window which it wasn't and and the content of the cvs output window consisted only of information about commit (or update when i did it).  I tried to change settings in Version Control -> Cache and in Local History but with no effect.  I am using Idea version 8.1   Thank you.  --  rk

3 comments
Comment actions Permalink

Hello Roman,

Delete the system\caches\vcsCache directory and restart IntelliJ IDEA.

Hello, is there any way how to disable this feature? The problem is
that after i do commit changes to CVS, the 'rlog' command is running
automatically for the whole project. And this is something i don't
need and don't want. I had to turn it on somehow when changing some
ide settings because rlog

output started appearing in cvs output window which it wasn't and and
the content of the cvs output window consisted only of information
about commit (or update when i did it). I tried to change settings in
Version Control -> Cache and in Local History but with no effect. I
am using Idea version 8

1 Thank you. -- rk

---
Original message URL:
http://www.jetbrains.net/devnet/message/5240368#5240368

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hi,

I've tried deleting that directory but Intellij still perform vcs refresh. Any other solution?
My problem is that refreshing vcs history takes ages and uses 100% cpu - I can't use Intellij and need to kill it's process. Adjusting vcs settings to keep only few change sets doesn't help.
It happens only when I'm using mercurial, svn and git plugins are pretty fast.

0
Comment actions Permalink

I would like to add that I have a very similar problem. I am currently watching build 133.79 constantly running from 2 to 5 simulataneous SVN processes. While these processes take up a small amount of the CPU, they appear to trigger an enourmous amount of activity in the Symantic and MS Anti-Malware services that I am required to run by my employer. This ends up running the CPU at 90% basically for nothing. Are constant, parallel SVN refreshes really necessary?

0

Please sign in to leave a comment.