First Grails Project Problem - ASSERTION FAILED

Hey,

First time using IntelliJ IDEA and going to start learning Grails right now but running dead smack into a problem I can't seem to get around.  I create a project, change nothing and try to run it and get the following error:

|Running Grails application |Server running. Browse to http://localhost:8080/GrailsTestingGround *** java.lang.instrument ASSERTION FAILED ***: "!errorOutstanding" with message transform method call failed at ../../../src/share/instrument/JPLISAgent.c line: 844 Exception in thread "main" Error | Forked Grails VM exited with error Process finished with exit code 1


I'm running this on Windows 7 64bit.  Have JDK 1.7.0_45 and Grails 2.3.2 with latest version of IDEA.

Any help would be appreciated as haven't been able to find solution searching as of yet.

4 comments

Do you mean that all you have done is the 'create-app' and then tried to run the application ?

I cannot say that I have ever done that - however, and in order to do some small tests on 2.3.x I have made several small projects where I run 'create-app', create a new domain class, add a couple of String properties and then generate-all (to make the controllers and views), then run the application (all within IDEA) and with both IDEA 12 and 13 EAP I have had no problems as you have described.

Is there anything in your app at all ?

graham

0

I tried both a blank project and before that by following first tutorial for grails project ( http://wiki.jetbrains.net/intellij/Creating_a_simple_Grails_application_with_IntelliJ_IDEA ) which resulted in same problem.

I'll try finding a working project and see if I can run it, guess that would tell me if it's just my projects which are bad though seems an odd error for that, or at least not very clear/helpful.  Any other ideas appreciated.

0

That really does seem odd. And I should mention that I do use linux - but that really shouldn't matter.

Could I suggest that you try outside of IDEA. You can run the already created Grails app from a grails prompt - I must admit that I seldom do this so I cannot guarantee to get it right...but if you CD to the project directory and type Grails (at a DOS prompt) it should load Grails (if the PATH is set up correctly etc.) and you can issue the Grails commands from there; indeed you can create a whole project just by running the commands...

And, of course, check PATH is pointing to the correct Java (I'm running the same version) and that JAVA_HOME and GRAILS_HOME are correct.

PS
I then did what we (?) should have done at first and did a quick search .... finding a few references but in particular:

http://jira.grails.org/browse/GRAILS-10756

so it looks like a Windows-related issue which you can circumvent by amending the BuildConfig.groovy

graham

0

Well I'd swear I searched multiple times for that to try and find the answer but you probably wouldn't believe me now ;)

Thanks fro the help.  Modifying the BuildConfig.groovy to add that dependency line worked like a charm.

"org.fusesource.jansi:jansi:1.11"
0

Please sign in to leave a comment.