Error: Grails SDK is not configured

Hallo Community!


We have been testing IntelliJ IDEA for a week.
We importet a Grails project from CVS reprository. The import process went fine however if we try to run the application we always get the error "Grails SDK is not configured".
Grails and Groovy are installed properly and both are working. The Paths GROOVY_HOME and GRAILS_HOME are set too.
When i do right click on the tree views and -> module settings -> libraries: it shows me the grails libraries( however GRAILS_HOME/diest/* are shown red).

We are running IntelliJ on SLES 10 64Bit
I am looking forward for an answere.

Umit

7 comments
Comment actions Permalink

Have you seen this thread?
http://jetbrains.net/devnet/thread/285873?tstart=0

If this does not work, you can add the Grails library by hand by defining it as a global library and then adding it to the project in the project settings.
--
Hope this help
Hans

0
Comment actions Permalink

hi

Thanks for an answere!
Yes i already saw the Thread but unfortunately it doesnt help to add the sdk.
When i press Run at the menu and then run configurations i get a notice that the grails sdk is not configured.

Do you know how i can configure the grails sdk?
because its already added in the libs



Attachment(s):
2.png
3.png
0
Comment actions Permalink

Hi,

You added jars from 'diEst' folder instead of 'dist'.

Maxim Medvedev

0
Comment actions Permalink

Ty for the answere that was the problem

However i didnt add anything there .... dont know where idea got this paths..
but it was the problem
thanks
Umit

0
Comment actions Permalink

Maybe the project in the repository has incorrect paths to Grails SDK or there really exists 'diEst' folder

Maxim Medvedev

0
Comment actions Permalink

Same problem here. We are using IJ12 in a very professional environment, but it's a fucking mess.
No solution, even after days.

0
Comment actions Permalink

I am working with IntelliJ 12.0.1 ultimate.
I have installed Grails 2.3.1 on my computer, but always got errors when trying to specify it as a Grails SDK-
"failed to create library. Looks like Grails distribution in specified path is broken. Cannot determine version."
I tried with Grails 2.3.0, but got the same error.
Then, I tried my luck with Grails 2.2.4, and I could finally get it work.

0

Please sign in to leave a comment.