AIR SDK 3.9.1030 and ANE problem

I have updated to AIR SDK 3.9.1030. I have a project with ANE. When test on emulator (no problem on real device), ADL show error "[AIR Debug Launcher]: Not supported native extensions profile". This is a bug on previous version of AIR SDK, it is not suppose to show in this new version SDK.

I try use comand line to launch the ADL and it work properly. So, i guess their somthing wrong with intellij and AIR SDK.

Envi: Intellij 12.1.6 on mac. AIR SDK 3.9.1030. Pure Action Script project.

14 comments

Can you please paste ADL command line used by IntelliJ IDEA (that doesn't work) and that you tried from command line (that works)?

0

AlexanderD wrote:

Can you please paste ADL command line used by IntelliJ IDEA (that doesn't work) and that you tried from command line (that works)?

Yes, that work, i try in terminal. wired?:|
0

i have delete the previous version SDK and I try clean the cache. reboot computer,reboot intellij. didn't work.

0

ADL command line used by IntelliJ IDEA is shown in the Run or Debug tool window. Can you please paste it here?
And please paste ADL command line that works from Terminal.

0

i just direct copy the command from intellij and paste in terminal to run. Then, it work in terminal.:|

"/Users/tsangwailam/Documents/Iphone Project/Digicrafts/library/air3-9_sdk_mac/bin/adl" -profile extendedMobileDevice -screensize iPhoneRetina -XscreenDPI 326 -XversionPlatform IOS -extdir /private/var/folders/hz/mc3t6lws2zsgtrw8jfk917m80000gn/T/IntelliJ_ANE_unzipped "/Users/tsangwailam/Documents/Iphone Project/Speedy Winner/Flow-Game/out/android/LinkTogetherIOS-android-descriptor.xml" "/Users/tsangwailam/Documents/Iphone Project/Speedy Winner/Flow-Game/out/android"

0

That's weird.
What ANEs do you use? Are they publicly available, i.e. can I try them?

0

Seem no mater which ANE.

Several ANE from https://github.com/freshplanet, tapjoy ANE,etc. I try one by one, it happen if i included any ANE in the application descriptor xml.

0

I have found that indeed there was this bug in AIR SDK 3.9 beta releases:
https://bugbase.adobe.com/index.cfm?event=bug&id=3637398
http://forums.adobe.com/thread/1297475

But it is marked as fixed in the today's final release 3.9.0.1030. And definitely the same command line launched from IntelliJ IDEA and form Terminal must work the same. Confused...

0

I reproduced the issue on Mac with AIR SDK 3.9.0.1030, but so far have no idea why this can happen.

0

Is that Intellij refer to old SDK or some old xml sceheme? But user in window seem no problem.

0

No, that's not old sdk or old schemes.
To evaluate the problem I wrote a single-class java app invoking adl:

new ProcessBuilder(adlCommandLine).start();

When I start this app using IntelliJ IDEA run configuration I get 'Not supported native extensions profile'. When I run the same java app from command line - emulator starts successfully. May be some difference in environment variables, but so far I haven't found any. Adobe has done something very tricky with AIR SDK 3.9 :).

Can you please open an issue for that: http://youtrack.jetbrains.net?

0

There are no issues with AIR SDK 3.9.0.1200.
Still have no idea what's wrong with 3.9.0.1030.

0

Thanks. It is ok now with the new SDK.

0

Please sign in to leave a comment.