Breakpoints not hit in Flex mobile app

I just setup IntelliJ for my mobile application and have been having trouble with my breakpoints hitting.  On one launch of my app the breakpoints had the green check inside them signifying they were valid, and the debugger worked great.  Every launch before or after that launch has not worked, and my breakpoints simply show a red circle.  Are there any specific steps I need to do when running an application to make sure the breakpoints work?

I'm running the latest version of IntelliJ, Flex 4.10.0, on an iPad running iOS 7.

Thanks!

6 comments

I need some more info to evaluate the issue:

1. Full content of the Debug Console
2. Debugger logs. To get logs please do following:

  • remove old logs (to find logs location use Help | Show Log)
  • edit file <IDEA installation>/bin/log.xml and add the following category there after the last appender:
...
    <category name="com.intellij.lang.javascript.flex.debug">
      <priority value="DEBUG"/>
    </category>
...

  • launch IntelliJ IDEA, reproduce the problem.


After that please attach log file here.

0

Debug Console:

"c:\program files (x86)\jetbrains\intellij idea 12.1.5\jre\jre\bin\java.exe" "-Dapplication.home=C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\4.10.0" -Dfile.encoding=UTF-8 -Djava.awt.headless=true -Duser.language=en -Duser.region=en -Xmx512m -classpath "C:/Program Files/Adobe/Adobe Flash Builder 4.7 (64 Bit)/sdks/4.10.0/lib/fdb.jar" flex.tools.debugger.cli.DebugCLI -p 7936
Apache fdb (Flash Player Debugger) [build 0]
Copyright 2013 The Apache Software Foundation.
Trying to connect to Player
Player connected; session starting.
[SWF] pl.mateuszmackowiak.nativeANE.NativeDialogs - 74,795 bytes after decompression
[SWF] com.distriqt.Dialog - 15,814 bytes after decompression
[trace] INFO:  Initialize Flex Support


Thanks



Attachment(s):
idea.log.zip
0

Nothing wrong in logs (except that debugger tool from Flex SDK says that it doesn't know your classes and can't set breakpoints there).
Are you sure that SWF is compiled with debugging enabled?

0

I'm not sure- I'm new to IntelliJ.  Is there something special I need to do to make sure it compiles for debugging?  I haven't noticed a pattern yet of why sometimes I can debug and sometimes I can't.  Even when I can't debug, the console is still showing trace statements.

Thanks

0
Is there something special I need to do to make sure it compiles for debugging?

If you compile SWF using IntelliJ IDEA then by default debugging is ON. It is controlled by 'Generate debuggable SWF' option at Project Structure | Modules | [your module] | [your build configuration subnode] | Compiler Options tab.

Even when I can't debug, the console is still showing trace statements.

That means that your SWF contains debug info and the problem is in the debugger tool (FDB) from the Flex SDK (IntelliJ IDEA uses it).
IntelliJ IDEA 13 EAP contains a patch for FDB tool that probably fixes the issue, can you please try it?

0

I've been using IntelliJ IDEA 13 EAP all day today and debugging is consistently working now.

Thanks a lot!

0

Please sign in to leave a comment.