Problem with Ctrl+Alt+C (extract constant shortcut)

Hello

I'm hoping someone has experienced (and solved) this issue. I'm having difficulties pinpointing the cause of this.

My "extract constant" shortcut is not working. Using this shortcut while the cursor is placed on a string literal, for example, does nothing. I can right click the literal and navigate the context menu to get to the extract constant refactoring option to successfully introduce the constant. While on this menu I verify the shortcut is Ctrl+Alt+C (which is the shortcut I'm attempting using.)

I'm running Window 7. I have verified I only have one keyboard layout (English US)

In IntelliJ I'm using the "Default" keymap. I'm using IntelliJ IDEA Ultimate v12.1.6 (build #IU-129.1359)

Does anyone have any ideas? All other shortcuts seem to work fine (e.g. extract variable: Ctrl+Alt+V)

Thanks
-- Cam

2 comments

I've given up on this. I don't think the problem is with IntelliJ. I eventually remapped "extract constant" to a new shortcut to get it working. Clearly something global in Windows 7 or some other program is intercepting the Ctrl+Alt+C shortcut, preventing it from getting to IntelliJ. Unfortunatley I can't figure out what that shortcut does or what program uses it.

0

I systematically terminated each running process on my system through Window's task manager until the Ctrl+Alt+C shortcut worked. It turned out it was
ATI's Catalyst Control Center (CCC.exe) that was intercepting the shortcut. I simply uninstalled it, which corrected the issue.

0

Please sign in to leave a comment.