Background color of JavaDoc comment

Hi,

I switched to the Darcula theme (IDEA 12) and wanted to change the way JavaDoc comments show up in the editor. At the moment, they show up with some short of semi-transparent green background. At the very least, I'd like to change how visible this background is. Where do I do this?

I've attached the screenshot of what I am talking about.

Thanks!
-yaakov.



Attachment(s):
screenshot.png
4 comments

File > Settings > [IDE Settings] > Editor > Colors & Fonts > Java > {JavaDoc comment}

0

Sorry, forgot to mention...

That's the thing. When I look at that configuration, it doesn't show any background color at all:
screenshot.png

Any ideas?

Thanks!
-Yaakov.

0

I think I found the solution.... in that there was not a problem to begin with. The reason I was seeing a strange green background was because the comment was part of a template. Once I edited the template, new classes I create no longer show the greenish background.

Mystery solved! ;)

-Yaakov.

0

Hello.

For a case you (or anybody) will meet this in the future. As I see from your last comment the strange background most likely was a superposition of javadoc background and an inspection's warning background. Inspections warning colors may be edited in Settings / Editor / Colors and Fonts / General category, Warning entry.

Regards,
Alexander.

0

Please sign in to leave a comment.