JBoss 7.2.0 Cleanest way to deploy exloded ear

Hi,

I'm evaluating Intelij Idea since 14 days. I have still little problems to work with intelij.

I try to deploy an exploded ear of my project. I have three problems with that.

1. When I chosse an exploded ear as deployment then I must rename the ouputfolder with the suffix ear
2. Atfer every clean build or after restsrat of the ide - intelij losts the configuration of the output folder.
3. Intlij tell me everytime that the dependenies not found. But all of them are in classpath. When I change my outputfolder to a folder with a suffix of .ear then the deployment will work. Bit the error report is still there.



Attachment(s):
IntelijJbossProblem1.png
3 comments

in your maven settings (maven > import) make sure to uncheck "Use maven output directories"

0

Thanks for response.

It seems so that the isolation of the build folder helps. But I have an another problem with that approach. One of my project compiles with rmic over mvn.  But the out folder (the idea compile folder) doesn't contains my stup classes. I thought the option  "Exclude build directory (PROJECT_ROOT/target)" maybe helps but it doesn't. Is there a way to tell intelij to copy the stups or compile with rmic as well ?

But the error reports for the artifacts are still present.

0

So I see that intelij can compile RMI as well. That approach works fine for me. Can you tell me when to use the option "Exclude build directory (PROJECT_ROOT/target)" and when not?

0

Please sign in to leave a comment.