Shift button isn't working to highlight text


For whatever reason when I hold down the shift key on the keyboard followed by a directional key, the cursor won't move to highlight text. Not sure if this is a setting that somehow got disabled.

Any ideas?

I am running Intellij IDEA 12.1.4 on Mac OS X Mountain Lion 10.8.4


I figured it out. Installing the VIM plugin it changed my keymapping. I changed the keymapping back to the default in Preferences -> KeyMap and then selecting it under the dropdown menu.


And, at least in my case, Ctrl-Shift-Arrow does extend selection.

I didn't see any change in the chosen keymap,no entry for vim appearing, everything as expected in the list of keys for Editor Actions, and choosing another standard keymap didn't help. So I just disabled and banned the IdeaVim plugin.


Patrick's solution worked for me too. The VIM plugin wrecked havoc with the editor shortcuts!


For me worked to go to Preferences --> plugins --> disable IdeaVim


Please sign in to leave a comment.