IDEA 7.0 - repeatedly "Updating Modified Files..."

This is driving me crazy. For no reason that I can see, the "Updating Modified Files" dialog pops up and every class file in my project is parsed, taking several minutes. When that finishes, I can work for another minute or two (sometimes less) and the "Updating Modified Files" dialog opens and does the same thing. And so on.
I can see no outstanding JIRA which matches this problem. Is any one else seeing this? I am running on opensuse 10.3 with jdk 6 if that makes a difference. I just finished asking the boss to organise licence upgrades so any help finding the cause will be much appreciated. I don't want to have to revert to using 6.0.6 :(

8 comments

Ian Booth wrote:

This is driving me crazy. For no reason that I can see, the "Updating
Modified Files" dialog pops up and every class file in my project is


I just had something similar to this due to "corrupt caches" when
compiling, deleting everything from my caches directories (from the
EAPs) seemed to solve the endless reparseing etc.

0

Hello Mark

Thanks for the reply. I should have mentioned that when I installed 7.0 is was to a clean directory and I also deleted my entire .Intellij70/system directory. When this problem occurs, if I go and delete my system directory all over again, I can again work for a time before it happens again :(

0

I just added a 'me too' to issue 14456

http://www.jetbrains.net/jira/browse/IDEA-14456

Both I and the original reporter are using Ubuntu 7.04. Please vote for this issue if you are experiencing it. IDEA is currently useless for me until I find a work around.

0

I can now reproduce this and also stop it from happening.

It starts when I do an ant build that compiles classes into my 'output' directory.
Intellij goes into an endless loop of 'Updating Modified Files'.

I can stop it by closing the app window (and waiting 5 minutes for the current parse cycle to end) and deleting the whole 'output' directory.

I will update the bug with this info.

0

did you try excluding the output directory from the module configuration ?

0

The output directory is excluded

0

I am using actually opensuse 10.3 - seems like a Linux issue? I went and voted for the jira so hopefully it gets fixed in the first 7.0x update :)

0

have you tried this?
settings -> IDE -> general
disable 'Synchornize files on frame activation'
and disable 'Save files on frame deactivation'

0

Please sign in to leave a comment.