Prevent ear/war from being built

This is probably a silly user question, but I couldn't find the setting.

I have a maven project in multiple modules, with an ear and a war.

when I compile and test some modules on which these ear and war depend, IJ always rebuild the ear and war. How can I prevent that?

2 comments

- Go to project settings (Ctrl + Alt + S, 1)
- For the Web module:
- Select the Web Facet
- In the 'Java EE Build Settings' tab, deselect 'Create web modular war file'.
- For the Ear module
- Select the Java EE Application Facet
- In the 'Java EE Build Settings' tab, deselect 'Create application archive (ear) file'.

Note that refreshing the Maven POM will reset these changes.

0

In 7.0.3 eap changes won't be resetted, provided that you import with 'regular idea modules' option.

0

Please sign in to leave a comment.