JBoss Debug Configuration: default JAVA_OPTS

Hi,
I am struggling to make my jboss debug config work :)
I am a newbie with intellij.
Configuring a local jboss configuration, Idea proposes some only-read JAVA_OPTS with '-Xrunjdwp:transport=dt_socket,address=8787,server=y,suspend=y'.
I'd like to modify it to "suspend=n" at the end.

Even adding it to VM args doesn't work.

How can I override those default JAVA_OPTS, please?

Thank you,
nic

3 comments

Why do you need this? IDEA uses 'suspend=y' option to ensure that all breakpoints will be properly registered in JVM before the process is started.


--
Nikolay Chashnikov
Software Developer
JetBrains
http://www.jetbrains.com
"Develop with pleasure!"

0

I've been using suspend='n' for years when debugging with IntelliJ. It's now an issue with IntelliJ? Is this a new issue in IntelliJ 12?

0

Hi,
the question was about the possibility to modify the default parameters.
Not about the nature of the parameters inside.

Thank you anyway for your answers :)
Best regards,
Nicola

0

Please sign in to leave a comment.