Failure on opening the 132.27 .gz

Over the several years that I've been using IDEA there have been the downloads that appear to work but when trying to open the archive there is some failure and , usually, just doing it again is sufficient.

However I have now tried to download build 132.27.tar.gz three times and while they all appear correct (the final two with identical sizes - 240467798 bytes ), the first was just via the browser (Opera) the final two using wget and they all downloaded without any apparent issues, when I try to open them with the standard Ubuntu Archive Manager (which I always use) I get


tar: This does not look like a tar archive

tar: Skipping to next header

gzip: stdin: invalid compressed data--format violated
tar: Child returned status 1
tar: Error is not recoverable: exiting now
The same for all three.

I know that you are going to say that it must be something to do with the internet connection - that's certainly what I would do in your place, but while to have one faulty download may be regarded as a misfortune; two to carelessness (*); but three really does seem quite seriously regrettable.

Any suggestions ?


graham

* acknowledgements to Mr. O. Wilde
2 comments

I've just downloaded this file and unpacked it using ubuntu archive manager without any problems. The size of your file is correct but maybe its
content is corrupted. Please check its md5sum, it should be eb3639baad2fc84e309759d510dccfdb.

--
Nikolay Chashnikov
Software Developer
JetBrains
http://www.jetbrains.com
"Develop with pleasure!"

0

Thanks - I obviously did not have a good weekend...

When I ran md5sum the value was, indeed, different so something must have gone wrong. However I did have another copy  - I usually download to one directory and then move to another to extract etc, - and that one did have the correct value and did extract correctly. All I can assume is that the first two were corrupted in some way but the third was fine but I simply tried to extract number 2 twice - if you see what I mean.

But: two points - would it be a good idea to publish the md5sum for the files as a check ? Secondly is there any real reason why two out of three downloads didn't work ? I don't download a tremendous amount but I do keep linux up to date so there is quite a volume of downloaded files that would fail if they were corrupted and, in general, I get very few problesm with the downloads, but, as I mentioned from time to time the IDEA ones do seem a problem.

graham

0

Please sign in to leave a comment.